
Running a Successful E-Commerce Program in Your Business 
 

David J. Mason 
  

Monday, June 9, 2008 

 
About 10% of the entire U.S. economy is flowing through the Internet using e-commerce technologies. Here is your chance 
to get a valuable overview of some current e-commerce techniques and the critical steps in the path to a successful online 
business. This presentation will provide new and experienced Internet users thoughtful points about running an e-
commerce program, will cover online selling techniques, and will introduce you to types of online monetary transactions. It 
will also suggest ways to promote your business online, point out Internet marketing strategies, and explain what you can 
do to improve your website performance and increase traffic.  
 
David J. Mason is Area Director of Fast Teks On-Site Computer Services, an international company with offices through-
out North America. Mr. Mason’s office serves business and residential customers in central New Jersey, including the 
communities of Hillsborough, Lawrenceville, Montgomery, North Brunswick, Pennington and Princeton. Fast-teks offers 
business owners and residential customers a one call solution for their entire computer needs. Fast-teks services include 
virus and Spyware removal, wireless networking, data back up and recovery, Web development, and remote management 
services.  

 

Mercer County’s Lawrence Library 
Meeting Room 3 

US Alternate Route 1 South & Darrah Lane, Lawrenceville, NJ 
 

Meetings of an organization at any of the facilities of the Mercer County Library System 

in no way imply endorsement of its programs. 

June 2008 Volume 24 Number 6 

PPCUGNEWS 

A PUBLICATION OF THE PRINCETON PC USERS GROUP 

In this issue: 
 

Meeting Minutes  ................................... 2 

Meeting Pictures  ................................... 2 

President’s Message  ............................. 3 

Link of the Month ................................. 3 

Home Financial Records  ..................... 3 

Get Ready for Service Packs  ............... 6 

 

 

Upcoming Schedule 
 

 
July 14, 2008  --------- Nancy Blachman - Google! 
August 11, 2008 ------ tba 
September 11, 2008  - tba 
October 11, 2008 ----- tba 
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About PPCUG 
 

Regular Meetings 
Second Monday of the month at the 
Lawrenceville Library, Alternate 
Route 1 and Darrah Lane. 
7:00 PM: Social Time / Tech Corner 
7:30 PM: Meeting comes to Order 
7:45 PM: Featured presentation 
 

For information about upcoming 
meetings or joining PPCUG, see: 

http://www.ppcug-nj.org 
or email us at: 

 ppcug.nj (at) gmail.com 
(Please include “OK” in the sub-
ject line.) 
 

Board Meetings  
Board meetings are held as needed. 
 

Board Members 
President: 
   Clarke Walker 609-883-5262 
Vice-President: 
   Tom Carman 732-828-6055 
Secretary: 
   vacant  
Treasurer: 
   vacant  
Members-At-Large: 

   Al Axelrod 609-737-2827 
   Kim Goldenberg 609-631-9140   
   Vic Laurie 609-924-1220          
   Sol Libes 609-520-9024 
 

Chairpersons 
Hospitality: 
   vacant 609-655-0923 
Member Records: 
   vacant  
Newsletter Editor: 
   Clarke Walker 609-883-5262 
Program Coordinator: 
   Arnold Rosner 609-586-1011 
Web Master: 

   Joe Budelis 609-921-3867 
 

2008 Annual Dues 
Dues are $40 per calendar year with a 
mailed newsletter or $20 per year 
with online access to the newsletter.  
New members pay $3.25 or $1.75 per 
month times the number of months 
remaining in the current year. 

    
Minutes of the May 2008 MeetingMinutes of the May 2008 MeetingMinutes of the May 2008 MeetingMinutes of the May 2008 Meeting    

 
At 7:30 p.m. Clarke started the Meeting.   
 
Clarke asked the members for their overview 
of the Trenton Computer Festival.  Most found 
the talks worthwhile but the sales area lacking 
in products. 
 
Sam Giraffe then gave us an overview of the 
latest Apple operating system Mac OS X. 

 
Submitted by Clarke Walker 

 

�������� 

 

Pictures from the May Meeting 
by Judge Landis,  judge@alumni.princeton.edu 

Member of the Princeton PC Users Group 

Sam Giraffe by Judge Landis 
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President's Message 
 
In  May I attended the APCUG’s Membership and Leadership Development Conference in Nyack, NY.  About 62 people 
attended the conference.  Most came from the Hudson Valley area but there were club members from as far away as Pitts-
burg, PA.  There were also attendees from two other New Jersey Clubs. 
 
About a third of the time was spent on running a club and the legal requirements.  Another third on various charity endeavors 
that a club can undertake.  The rest of the time was a trade show with Magix, Microsoft and Pinnacle the major exhibitors. 
 
It was a very useful experience and the APCUG plans to hold additional Regional conferences like this.  I hope we can 
gather a host committee to sponsor one in our area. 
 
As time permits I will share the information I learned. 
 

- Clarke Walker 

�������� 

 

Link of the Month 
 
These recommended sites came from the New York State Assistant Attorney General Mark Hoops: 
 

www.fakecheck.org 
www.hyperdynesoftware.org 
www.annualcreditreport.com 

(Not “free…”) 
 
Have you discovered a useful link or add-on?  Then share it with the members of the P PC UG. 
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Home Financial Records 

  
by Richard Kennon,  editor (at) acug.net  

 Editor, Amador Computer Users Group, CA, www.acug.org 

 
On August 7, 2007 Dick Johnson gave us an excellent presentation on “Personal Finances” with empha-
sis on record keeping and check writing. I, like Dick, have used QuickBooks to write my checks and 
keep my financial records. Recently, a friend chided me for not using BillPay at my bank. I had looked 
into this a long time ago and determined that my bank charged a little more than it cost to write a check 
and mail it – so no good. After my friend prodded me to join the 21st century, I checked with my bank, 
again, only to discover that if they changed the name of my checking account, BillPay would be free. 
Done. So, I write many fewer checks than before. Perhaps I can write them by hand! (Gasp) That is rea-
son #1 for this effort. 
 
Reason #2 is that the average household (at least mine) does not need the sophistication of an accounting program to keep 
household records. About the only thing we need besides a check record (i.e. stubs) is a way to collect some information for 
the IRS each year. Twenty or twenty five years ago, I wrote such a program in Basic and used it for most of those interven-
ing years. But, Bill Gates decided that he would no longer let me run Basic programs using his latest operating system. That 
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program also printed the checks on an old Epson 24-pin printer that served wonderfully for at least twenty years. That is when 
I turned to QuickBooks. 
 
These two intersecting forces of minimal “accounting” and lowered demand for check writing led me to wonder if, just 
maybe, an Excel spread sheet might do the job. Yes, I think it will. This thinking has resulted in a spread sheet that looks sus-
piciously like a check record in your check book. There are four added columns and they are “Account”, “Memo”, “Cleared” 
and “Reconciled.” Maybe “account” is too grand a term. What I mean it to be is a code name that may apply to a number of 
different checks written to a number of different payees. This might be like lumping the electric, gas, water and phone bills 
under “Utilities.” Or, lumping Red Cross, American Cancer Society and Yosemite Fund under “Contributions.” But, then, 
one might write enough checks to one organization (i.e. Church at The Cross) to make that a separate “Account” like 
“Church.” The Cleared and Reconciled columns are useful when it comes time to see if you and the bank agree. This is such 
an anxious moment that I use smiley faces to indicate it is done. Here is an example of what the spread sheet looks like. It is 
assuredly a fictitious account because I don’t think I know anyone with this much money. 
 

I had to scrunch it together to print it here. It looks better on 
the Excel spreadsheet where I set it up to print in Landscape 
orientation so there is plenty of room for about 48 lines per 
page. There are lots more accounts you will want to use such 
as Taxes, Medical, Insurance, House Payments, etc. I am a 
terrible organizer so I am sure you can do a better job of this 
than I can. Think mostly of what you need for outside de-
mands like the IRS. Don’t think in terms of detailed budgets 
because, admit it, you are not going to follow through with 
that. It seems as if I should be much more organized than I 
really am when I use QuickBooks or other accounting pro-
gram. That is why I have a big “Miscellaneous” group in our 
personal records. That is none of the IRS’s business. 
 

One nice thing about Excel is that when you start to type something you have typed above in the same column, Excel finishes 
the entry for you. So, we two-fingered typists can create entries more quickly later in the year! I have anticipated that you and 
I will make less than 400 entries per year so have activated 400 lines on each sheet. Of course, the spreadsheet does the calcu-
lations automatically. The sheet is locked except for the columns where entries are required. 
 
Now, how do we find out how much we gave to charity for the IRS? On the spreadsheet there is a little down arrow by each 
of the column headings that can be searched. Like this. 
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I have clicked on the Account column arrow and a choice box has dropped down. I have selected “Miscellaneous” and once I 
did that, this display popped up. 

 
Do that for any other account name or payee name and you will have the information you need for preparing your income 
tax. You can print this sub-list in the usual way. Now, to get out of this, click the arrow in the same column and then click on 
(All). The original full list will show up. You can do that operation in either the Payee or Account column and you will have 
all you need to find out how much money you have spent in any given category. For some fun, you can click on the arrows 
in the Check Number column and search for a check number or all the checks over some number or under a certain number. 
You can do the same in the Date column. This may come in handy when the sheet grows large late in the year and you want 
to find an entry made on or before or after a certain date. 

 
I did that here on the Check # column. Then I selected (Custom…). That sounds a little scary, doesn’t it? It’s not. The next 
thing to pop up is: 
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You can choose “is greater than” or any other descrip-
tion of what you want to find. Then, on the right you 
type in the amount, say 500. Click OK and all the 
checks with numbers greater than 500 will pop up. 
Again, close this out by clicking the arrow and then 
(All). 
 
 
A word of caution – be consistent. That is, do not call 
the electric company “PG&E” one time and “Pacific 
Gas & Electric” another time. Do not call an account 
“Charity” one time and “Contributions” another time. 
Keep it simple. Life would be simpler if we did not 
have to pay so many bills and it is also simpler if you 
use fewer accounts. Miscellaneous is a wonderful ac-

count. 
 
Printing may also present a challenge. If you click View>Page Break Preview, you will see that 400 lines cover eight pages. 
If you just click File>Print>OK, you will get the pages you want plus all the blank pages up to eight. So, In order to get just 
what you want, click on View>Page Break Preview first to see what pages you want. Then you can select just those pages in 
the print window. 
 
I will be glad to share this spreadsheet with anyone who wants to look at it more closely with the usual disclaimers about it is 
not my fault if you go bankrupt and so forth. You can copy the last blank sheet as many times as you wish so the workbook 
can last forever. 
 
If you are interested in constructing your own spreadsheet, here are some particulars that might be of interest. What I call the 
search option is accessed by clicking on Data> Filter> AutoFilter. If you do this while in the Payee heading, it will put the 
arrows and the function in all the contiguous headings to the right. I put a blank column after the Memo heading so it would 
stop there. The formula in the Balance column below the Beginning Balance is (are you ready for this?). =IF(OR(E9<>"", 

F9<>""), H8-E9+F9, ""). This is not so complicated. The classic IF statement says something like this: “IF(something is 
TRUE, then do this, else do that).” Now, the ‘something is true’ part says if cell E9 is not equal (<>) to blank (“”) or cell F9 is 
not equal (<>) to blank (“”). That is, if either of the two cells under the Amount heading or under the Deposit heading is not 
blank then… do some arithmetic. That arithmetic is subtract the Amount of the check and add the amount of the Deposit to 
the previous Balance, H8-E9+F9, in line number 9. The ‘else do that’ is leave this cell blank (“”). That is why all the cells 
below the active row are blank but will light up with a balance as soon as an entry is made. Just click on the + in the lower 
right corner and drag this formula down 400 rows. Isn’t this slick? 
 
With BillPay in full swing, I find that I write many fewer checks but I still have to keep a record, don’t I? The bank record is 
handy on the web but it only shows those charges that have cleared. I want to know whether I am solvent if they all clear. So I 
need a record. My accounting needs are mostly limited to keeping a ready record for tax purposes. Budgeting is not my thing. 
For these reasons a check record with the addition of an “Accounts” and a “Memo” column is satisfactory. The frosting on 
the cake is the added feature of being able to isolate various accounts and payees for whatever reason. While I may have 
made the transition to the 21st Century, I have also simplified my life somewhat by not being dependent on Intuit to write my 
checks for me and demand that I account for every last penny. How often is it that computers simplify your life?  
 
This article may be used in any non-profit publication if credit is given the author and the Amador Computer Users Group of 
Jackson, California. 
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Get Ready for XP and Vista Service Packs 925 
       

by George Whitesell,  pcug (at) Comcast.net 
Member of the Sarasota PCUG, Florida, www.spcug.org 
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Service Pack 1 for Windows Vista and Service Pack 3 for Windows XP are going to be released soon, 
perhaps even by the time you are reading this.  I recommend not being one of the first on your block to 
install either of the new service packs.  Let others discover any problems with the installation of the 
final versions of the Service Packs! 
 
What are service packs?  They are a compilation of all critical updates released since the initial release of an operating sys-
tem or the last service pack. They often contain new features or enhancements as well.  Service Pack 2 for Windows XP 
contained a number of security improvements and was arguably the most significant Service pack ever released.  I think it 
was only because of the negative publicity Microsoft was receiving over weak security that led them to release it as a free 
Service Pack and not “Windows XP Second Edition” which they would have charged us for.  You will not see any major 
changes or additions to XP in Service Pack 3 but you will still want to install it.  Service Pack 1 for Vista is reported to have 
sped up some aspects of the operating system. 
 
There is an article at http://support.microsoft.com/kb/935796 listing 11 programs that are blocked, do not run, or have a 
“loss of functionality” after the installation of Service pack 1 for Vista.  Three of the programs listed are Zone Alarm, Bit-
Defender AntiVirus or Internet Security and the New York Times Reader.  Check the list before you install the service pack.  
Personally I will wait at least one week (maybe more) to make sure there are not any other problems that are affected by the 
final release of either new service pack.  If you have been installing all Microsoft updates as they were released, you already 
have most of the service pack installed. 
 
Here are some general guidelines for the installation of any service pack: 
 
1. Run complete scans of your computer for viruses and spyware.  A majority of the problems people encountered while 

installing Windows XP Service Pack 2 were caused by viruses and/or spyware on their computer.  Service packs re-
place or update a number of system files.  You want to make sure your computer is free of any malware. 

2. Fix any hardware or software problems.  If you are experiencing frequent lockups or system crashes, or extremely slow 
performance, resolve those problems before trying to install a service pack.  Many people assume the installation of a 
service pack will clear up problems they may be experiencing.  This usually is not the case.  This is another frequent 
cause of service pack installations failing or causing more problems. 

3. Create a System Restore point.  If you found any viruses or spyware delete all of your old Restore Points and then cre-
ate a new one.  If you have a problem and use a System Restore point prior to the time you removed any viruses or spy-
ware, guess what happens?  That’s right; you reload the viruses and/or spyware!  Instructions on deleting System Re-
store points are at the end of this article. 

4. If you installed a beta version of a service pack, uninstall that version before you install the final service pack. 
5. NEVER attempt to abort the installation of a service pack (or any program).  If you have started the installation and 

then decide you do not want to continue, allow the installation to complete; reboot the computer; and then uninstall the 
service pack (or program). 

  
Follow the steps below if you need (or want) to delete all System Restore points: 
 
Windows XP 
 
1. Click the Start Button. 
2. From the Start menu click Control panel. 
3. Click on “Switch to Classic View” in the upper left portion of the Control Panel window. 
4. In Control Panel double-click the “System” Icon. 
5. Click the “System Restore” tab. 
6. Check the box next to “Turn off System Restore on all drives”. 
7. Click “Apply” at the bottom right corner. 
8. Click “Yes” in the warning box asking if you want to turn off system restore. 
9. Click “OK” and close all windows. 
10. Reboot the computer to clear all System Restore points. 
11. To re-enable system restore repeat the above steps; this time removing the check in the box next to “Turn off System 

Restore on all drives”. 
12. Reboot Again. 
 



Windows Vista 
 
1. Click the Start Button. 
2. From the Start menu click Control panel. 
3. Click on “Classic View” in the upper left portion of the Control Panel window 
4. In Control Panel double-click the “System” Icon. 
5. On the Left of the System properties window you will see a list of Tasks, click on the “System protection” link.   
6. Click “Continue” on the ‘User Account Control’ box if it appears. 
7. In the System protection window remove the “check”' mark for the drive you want to disable system restore on. A message 

will now appear asking: ‘Are you sure you want to turn System restore off'. 
8. Press the “Turn System restore Off” button. System Restore will now be turned off permanently on that particular drive. 
9. Click “OK” and close all windows. 
10.  Reboot the computer to clear all System Restore points. 
 
To re-enable system restore repeat the above steps, but click the box next to the drive you require system restore to monitor ( a 
check will appear in the box), then click the Apply button and system restore will resume monitoring the drive. 
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* * These articles may be published only by APCUG member user groups. All other uses are prohibited. When used, APCUG must be 

acknowledged as the source and the author credited. The Editorial Committee of the Association of Personal Computer User Groups 

(APCUG), an international organization of which Princeton PC Users Group  is a member, brings their articles to you. * * 

 
  

All unattributed articles are solely the fault of the editor. 

 

This and previous Princeton PC User Group Newsletters can be found at: 

 

http://www.ppcug-nj.org/newsltr.html 
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